Problème pour grabber

Tout ce qui concerne le package XMLTV officiel.

Modérateurs : Modérateurs, Développeurs

Règles du forum
Rappel: Conditions générales d'utilisation du forum zguidetv.net

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.

Pensez également à consulter les FAQ

On ne hurle pas, on respecte l'opinion de chaque personne, on reste aimable et on respecte le travail des autres, c'est la base d'une entraide constructive.

Tout post ne respectant pas les Règles du forum sera effacé sans préavis.
Avatar du membre
globulerouge
VIP
Messages : 58
Enregistré le : 12 avr. 2006 18:10

Problème pour grabber

Message non lu par globulerouge » 09 août 2006 16:42

HellO,

je me lance dans le grab depuis peu mais pour l'instant soit le fichier obtenu n'est pas valide -> ERREUR 6, soit le grab ne se finit pas et plante ...

qu'en est-il pour vous ... ?


GR

Avatar du membre
Jacky67
Modérateur
Messages : 132
Enregistré le : 24 mars 2006 19:14

Message non lu par Jacky67 » 09 août 2006 21:58

Ben apparemment pas de problème chez moi : http://bart63.ifrance.com

Néo
Développeur ZGuideTV
Messages : 1751
Enregistré le : 22 mars 2006 13:40
Localisation : Bruxelles, Belgique
Contact :

Message non lu par Néo » 09 août 2006 22:04

c'est bien la preuve que, les gens qui ont une "erreur 6" sous ZGuideTV, cette erreur ne viens pas de ZGuideTV en lui même mais d'un fichier .xml non valide !!

non ??!! heu !! :lol:

qu'en pensez vous ?

++ Néo
Le site de K!TV : http://www.kastortv.org
L'aide de nxtvepg pour K!TV : http://www.nxtvepg-kastortv.org
L'aide de ZoomOut pour K!TV : http://zoomoutktv.sourceforge.net/help/fr/index.htm

Avatar du membre
globulerouge
VIP
Messages : 58
Enregistré le : 12 avr. 2006 18:10

Message non lu par globulerouge » 09 août 2006 22:12

Merci Jacky et néo.

Jacky : as-tu essayé de grabber en --slow ?

Avatar du membre
globulerouge
VIP
Messages : 58
Enregistré le : 12 avr. 2006 18:10

Message non lu par globulerouge » 09 août 2006 22:18

euh... l'archive ne semble pas valide mon jacky ...

Avatar du membre
Jacky67
Modérateur
Messages : 132
Enregistré le : 24 mars 2006 19:14

Message non lu par Jacky67 » 09 août 2006 22:56

J'ai testé l'archive avant mon post précédent et elle fonctionne bien quand c'est ZGuideTV qui l'ouvre lui-même.

Je n'ai pas encore testé en slow, mais je crois bien que je veis tester bientôt...

Avatar du membre
globulerouge
VIP
Messages : 58
Enregistré le : 12 avr. 2006 18:10

Message non lu par globulerouge » 10 août 2006 8:01

HellO,

je viens de réinstaller Zguide b11, je viens de retélécharger le Zip de jacky (modifié cette nuit à 3h et des brouettes ... faut faire dodo quand même), et lorsque je lance la mise à jour ... erreur 6 ! :grrr:

Qui a une idée ?


GR

Starcrasher
VIP
Messages : 550
Enregistré le : 31 mars 2006 18:30
Localisation : Perdu dans l'immensité galactique...

Message non lu par Starcrasher » 10 août 2006 9:51

Par expérience, avec les récupérations faites de nuit les programmes sont généralement pleins de trous ou décalés d'une journée. La mise à jour du site se prolonge quelquefois très tard dans la matinée. Si des modifications sont effectuées sur le site, il arrive également que le programme des chaînes concernées soit totalement vierge, indépendement de l'heure. Résultat, je préfère récupérer les programmes vers 11H30 en "slow" sur deux jours. Cela évite aussi d'avoir un .xml trop gourmant en mémoire.
Une autre source de problème peut etre le grabbeur en lui-même.
A priori le script n'a pas été modifié depuis le 19 Mai 2006 (version:1.62) mais le reste continu d'évoluer et un snapshot récent de l'éxécutable est quand même recommandé.
Voilà pour être à peu près sur d'obtenir un fichier valide.

GR: Peut être essayes tu d'afficher une chaîne avec laquelle il y a un problème dans la récupération ? J'imagine qu'avec les vacances Jacky67 récupère plus de chaînes qu'il n'en sélectionne pour lui-même. Ce qui expliquerai que l'erreur ne se présente que chez toi.

Mon grab vient de se terminer (sous Linux) et il n' y a pas de programme pour Direct 8 NRJ 12, Europe 2 TV et AB Moteurs (programme vierge). Mais, comme je ne récupère pas toutes les chaînes, la liste n'est pas exhaustive.
Il faudra voir ça après le Week-end. J'imagine que les mises à jour du site sont encore plus lentes que d'habitude vu les vacances. Et si ça persiste, Biboobox mettra son script à jour une fois de plus.

Avatar du membre
Jacky67
Modérateur
Messages : 132
Enregistré le : 24 mars 2006 19:14

Message non lu par Jacky67 » 11 août 2006 0:35

Je n'ai pas de problème pour utiliser mon fichier ZIP, mais il y a effectivement quelques chaînes qui n'ont aucun programme. :(

Avatar du membre
globulerouge
VIP
Messages : 58
Enregistré le : 12 avr. 2006 18:10

Message non lu par globulerouge » 11 août 2006 9:00

Qui pourrait tester ce xml pour me dire si cela vient de là http://sitedeglobulerouge.free.fr/xmltv7.zip

Si ce xml fonctionne c'est que cela vient de ZGuideTV ... :?:

GR

Néo
Développeur ZGuideTV
Messages : 1751
Enregistré le : 22 mars 2006 13:40
Localisation : Bruxelles, Belgique
Contact :

Message non lu par Néo » 11 août 2006 10:14

kikou GR,

pas d'erreur avec ton .xml... mais sur 38 chaines beaucoups sont vides et rien dans "ce soir" ...

:wink:

PS : j'utilise la future beta !!!
Le site de K!TV : http://www.kastortv.org
L'aide de nxtvepg pour K!TV : http://www.nxtvepg-kastortv.org
L'aide de ZoomOut pour K!TV : http://zoomoutktv.sourceforge.net/help/fr/index.htm

Avatar du membre
globulerouge
VIP
Messages : 58
Enregistré le : 12 avr. 2006 18:10

Message non lu par globulerouge » 11 août 2006 12:02

mais mon soucis c'est que moiu je n'ai RIEN !!! Directement erreur 6 !

je n'arrive à rien faire... Je vais à nouveau désinstaller ZGuideTV puisque cela vient de là ...


GR

Néo
Développeur ZGuideTV
Messages : 1751
Enregistré le : 22 mars 2006 13:40
Localisation : Bruxelles, Belgique
Contact :

Message non lu par Néo » 11 août 2006 12:06

GR,

dé-installe ZGuideTV ensuite tu vas dans "C:\Program Files\ZGuideTV" tu efface tout sauf le répertoire "logos" ... tu réinstalle .. et tu teste :wink:

++ Néo
Le site de K!TV : http://www.kastortv.org
L'aide de nxtvepg pour K!TV : http://www.nxtvepg-kastortv.org
L'aide de ZoomOut pour K!TV : http://zoomoutktv.sourceforge.net/help/fr/index.htm

Néo
Développeur ZGuideTV
Messages : 1751
Enregistré le : 22 mars 2006 13:40
Localisation : Bruxelles, Belgique
Contact :

Message non lu par Néo » 11 août 2006 13:14

en fait,

si on efface les fichiers DB_Progs.mdb et config.ini et que l'on relance ZGuideTV et importe le fichier .xml il n'y a plus de pb !! nan ?

GR ??? :lol:
Le site de K!TV : http://www.kastortv.org
L'aide de nxtvepg pour K!TV : http://www.nxtvepg-kastortv.org
L'aide de ZoomOut pour K!TV : http://zoomoutktv.sourceforge.net/help/fr/index.htm

Avatar du membre
The Real Mc Coy
Administrateur - Site Admin
Messages : 321
Enregistré le : 22 mars 2006 13:16

Message non lu par The Real Mc Coy » 11 août 2006 14:18

Comme le grab de caku n'est pas dispo je grabbe moi même mais sur une selection de chaines... Seules les chaines ciné de TPS ont des programmes vides et les autres sont ok même si en grabbant sur 9 jours certaines chaines n'ont de programmes que pour 7 jours ;)

Je n'ai pas réussi a obtenir un XMLTV complet (toutes les chaines sur 9 jours) pour l'instant en mode slow.
The Real Mc Coy
Administrateur

Répondre